Actualizar Kernel, Mesa e Xorg en Ubuntu 14.04 Trusty Thar

Como ben debedes notar os poucos que entrades neste humilde blog, este non é un blogue de noticias, senón mais ben de cousas que me interesan e me son utis a diario, e que comparto aquí por si a alguén lle pode valer. Nesa liña vai o que a continuación vos vou  contar.

Probablemente moitos de vos usedes, coma min, a última LTS de Ubuntu, tanto por estabilidade, soporte, como por ser referencia dos desenroladores de software a hora de facer os seus programas, drivers, etc. Eso implica en moitos casos non estar a última, pero afortunadamente Ubuntu saca cada certo tempo revisións actualizadas da sua LTS que melloran aspectos básicos da sua distribución.

trusty-tahrHai case un mes lanzouse Ubuntu 14.04.4 que incluía, entre outros arreglos e melloras, o Kernel 4.2, Mesa 11.0 e Xorg 1.17.2; caracteristicas mais que xustificadas para que nos interese actualizar. Se non queremos descargar e instalar dende cero o noso sistema simplemente debemos abrir coma sempre unha terminal e copiar/pegar o seguinte:

sudo apt-get install –install-recommends linux-generic-lts-wily xserver-xorg-core-lts-wily xserver-xorg-lts-wily xserver-xorg-video-all-lts-wily xserver-xorg-input-all-lts-wily libwayland-egl1-mesa-lts-wily

No caso probable de que teñas aplicacións de 32 bits instaladas no sistema (por exemplo Wine ou Steam) utiliza entón o seguinte:

sudo apt-get install –install-recommends linux-generic-lts-wily xserver-xorg-core-lts-wily xserver-xorg-lts-wily xserver-xorg-video-all-lts-wily xserver-xorg-input-all-lts-wily libwayland-egl1-mesa-lts-wily libgl1-mesa-glx-lts-wily libgl1-mesa-glx-lts-wily:i386 libglapi-mesa-lts-wily:i386

NOTA IMPORTANTE: Fixádevos nunha cousa, antes de onde pon “-install-recommends” realmente debe levar dous guións o principio de todo en troques de un. Supoño que é un erro de wordpress, xa que polo que vexo noutros sitios non me pasa só a min.

Probablemente non o precises, pero é moi recomendable que o reiniciar o sistema reconfigures o servidor gráfico:

sudo dpkg-reconfigure xserver-xorg-lts-wily

Saudos e espero que vos sexa útil

Si che gustou este artigo, por favor pincha na publicidade.
-Grazas-

33 reflexións sobre “Actualizar Kernel, Mesa e Xorg en Ubuntu 14.04 Trusty Thar”

  1. Ola de novo, Leo.

    Xa hai tempo que non escribías e o tema interésame.

    Eu son, como sabes, dos que teñen cousas de 32 bits (Wine non gasto, pero teño Steam).

    E a pregunta vai sobre os riscos potenciais da actualización. É certo que aos que nos gusta darlle aos videoxogos, ter actualizado o kernel e o stack gráfico nos pode vir ben. Pero tamén é certo que estas cousas sempre teñen un risco. A min, polo menos, sempre me deu algo de yuyu facelo.

    Resumindo, ten moito risco a cousa?

      1. Home, o mes que vén non creo, máis ca nada porque me parece boa cousa darlle un tempiño ás novas versións para que se vaian asentando, que se vaian actualizando todos os PPAs que uso, etc.

        Pero, salvo que 16.04 sexa un desastre, cousa que non parece, moito non hei tardar, non. Tampouco é que pareza que vaia traer unha barbaridade de cambios na experiencia de usuario, pero si que mellora cousiñas que eran bastante molestas nas anteriores versións de Ubuntu.

        Non che sei. Haberá que ir vendo.

        1. E outra cousa.

          Respecto daquilo de desinstalar antes todo o relacionado con nVidia para minimizar os riscos, como o ves?

          1. Ola Leo.

            Como son medio cabezón e, hai que recoñecelo, apetecíame fozar un pouco, púxenme ao tema cos drivers nVidia desinstalados, pero devólveme un erro que che pego aquí:

            “Non foi posíbel instalar algúns paquetes. Isto pode significar que solicitou
            unha situación imposíbel ou, se emprega a distribución inestábel, que
            algúns paquetes solicitados aínda non se creasen ou que se movesen da entrada.
            A seguinte información pode axudar a solucionar a situación:

            Os seguintes paquetes teñen dependencias sen cumprir:
            account-plugin-google : Depende: libaccount-plugin-google mais non se vai a instalar ou
            ubuntu-system-settings-online-accounts mais non se vai a instalar
            indicator-bluetooth : Depende: unity-control-center mais non se vai a instalar ou
            gnome-control-center mais non se vai a instalar ou
            ubuntu-system-settings mais non se vai a instalar
            indicator-network : Depende: unity8 (>= 7.82) mais non se vai a instalar
            libqt5feedback5 : Depende: libqt5multimedia5 (>= 5.0.2) mais non se vai a instalar
            libqt5quick5 : Depende: libqt5gui5 (>= 5.2.0) mais non se vai a instalar
            E: Erro, pkgProblemResolver::Resolve xerou interrupcións, isto pode estar causado por paquetes retidos.”

            O caso é que non teño paquetes rotos no sistema neste momento.

            Tes idea de que pode ser?

          2. Os drivers de nVidia desinstaleinos gráficamente, a primeira vez desde Synaptic e despois desde a Controladores adicionais.
            Agora que mo comentaches probei “sudo at-get install -f” e non pasou nada.

            Acto seguido apliqueille “sudo dpkg-reconfigure -a” e a terminal púxose a facer unha cheaza de cousas que, con franqueza, non entendía moi ben, desde os permisos por defecto dos cartafoles ata a instalación de certificados de seguranza, por precaución aceptei todas as opcións por defecto e, certamente, tampouco che estaba eu para andar a cambiar opcións porque non che entendía moito, máis aló do tema dos permisos.

            Non che fixen nada máis. Agora voulle aplicar un reinicio.

            Xa me contarás.

          3. Acabo de reiniciar e todo parece funcionar ben. Imaxino que ao deixar todas as opcións por defecto non me cargaría nada.

          4. En calquera caso, é raro o erro ese que me daba. Estou por lle aplicar outra vez o comando da actualización, a ver se agora o segue a dar, ainda que sexa con drivers nVidia e todo.

            Que me dis?

          5. Cóntoche máis.

            Deume por arriscar con drivers instalados e todo e volvo ter o mesmo erro.

            Algo raro hai aí.

          6. Estaba agora maquinando sobre o tema este veume á cabeza a posibilidade de que non se puidera actualizar directamente desde o kernel da primeira ISO de Ubuntu 14.04 ata este último da ISO 14.04.4.

            Podería ser este o motivo do erro? Como o ves?

          7. Non o podo mirar agora porque non estou na casa, pero tendo en conta que nunca o actualicei, máis aló dos parches e revisións que saen a cada pouco, tería que ser a que traía a primeira ISO 14.04 ou, como moito, a ISO 14.04.1.

            Dígocho con seguridade á tarde.

          8. Ola de novo.

            Xusto agora acaba de haber unha actualización do kernel que deixou instalada a versión 3.13.0-83.

          9. Si, tío. Moi normal non parece.

            Ando a buscar por internet algunha referencia e vexo casos de erros de dependencias non resoltas de todo tipo, pero nada que se lle pareza a isto.

            En Ubuntu-Guía por agora nada.

            A saber.

          10. Mira ti, acabo de atopar en ask ubuntu un problema clavadito, só que para outra versión do kernel…

            Iso si, sen solucionar… non se pode ter todo!

          11. No grub non che deixa seleccionar o kernel mais novo?

            Proba a ver si che deixa con 4.2 e logo fai un “sudo update-grub”

            Despois podes desinstalar os kernel vellos. Eu uso o Ubuntu-tweak na opción de limpieza.

          12. O kernel máis recente instalado é a revisión do 3.13 que veu esta tarde, a 3.13.0-83.

            Non hai nada máis novo. Cando intento instalar o 4.2, simplemente sae o erro ese que che comentei de que non da resolto as dependencias e nin chega a descargar nada.

            Eu tamén uso Ubuntu Tewak para estas cousas, pero agora, ningunha versión máis alta ca a 3.13.0-83.

            O que está claro é que o problema existe e que hai máis xente que o ten, ou que o tivo cando quixo dar o salto ao kernel de utopic, por exemplo, que diso si atopei referencias, pero nada que deixara claro que o problema se resolvera como é debido.

          13. “Pues no te se”, proba. Senón podes tratar de engadir “libgl1-mesa-glx-lts-utopic libgl1-mesa-glx-lts-utopic:i386 libglapi-mesa-lts-utopic:i386”.

          14. E para o kernel 3.16 non hai que facer nada respecto das aplicacións de 32 bits?

            No meu caso, polo menos, estaría Steam.

          15. Pois non sei que dicirche, porque, picar, pícame a curiosidade. Este tipo de erros raros próenme e non me pasa o pruído ata que os amaño.

            Pero tanto problema xa me da yuyu, francamente, non me presta a idea de cargarme o sistema a estas alturas.

            A ver.

          16. Ola Leo.

            Como me proía o tema, decidinme a probar co kernel utopic, como me comentaras, pero tampouco resolve dependencias e, de feito, o erro é o mesmo. Hai aí algo que impide que o kernel se actualice e, polo que se ve, tanto ten a versión que trate de instalar.

            Vamos, que no meu caso actualizar o kernel é misión imposible.

            Supoño que seguirei mirando por aí de cando en vez, moitos problemas menores coma este acabei polos solucionar co tempo, algún ata un ano despois, aínda que non creo que sexa o caso deste, estando aí Ubuntu 16.04, pero, mirar, hei de seguir mirando.

            Saúdos.

  2. Benvido de novo. Os teus comentarios sempre son ben recibidos.

    En canto o risco, si existe, ainda que si che son sincero pasaba mais antes que agora. Recordo que hay anos actualizar o kernel a unha versión superior (non unha revisión) as veces daba fallo, pero bastaba con escoller no grub unha versión anterior do kernel. Logo podias tentar repetir o proceso ou reparar o problema; ou senón desinstalar o kernel problemático e fora.

    A verdade é que xa teño feito este proceso unhas cantas veces no meu choio e ultimamente non tiven problemas nunca. Xa o fixen nuns 15 ordenadores en varias revisións do kernel. O kernel orixinal era o 3.13, e xa actualicei a 3.16, logo a 3.19 e agora a 4.2.

    Penso que o problema pode andar si tes drivers privativos e ten que volver a meter o módulo no kernel e hay algún problema, pero como che digo fai bastante tempo que non me pasa.

    Algunha vez que me paso isto o que fixen foi en modo recovery desinstalar o driver nvidia (nvidia-361, nvidia-358, ou o que sexa) e nvidia-settings e logo reiniciar. Normalmente arricaba co nouveau o xenérico. Logo tentaba instalar de novo os drivers privativos.

    En todo caso, si tes medo fai unha copia de seguridade e xa está

  3. Igual incluso o máis sensato puidera ser desinstalar antede de nada os drivers de nVidia e evitamos problemas.

    Mirarei, a ver. Pero quería evitar ter que facer unha reinstalación agora que queda tan pouquiño para a 16.04.

    Fñixate que, casualmente, esta semana empecei a ter problemas cunha actualización de numix-icon-theme, que daba erro de disco cheo, cousa que non era certa porque a raíz estaba ao 65%, e non daba atopado o problema. E básicamente, a cousa era que quedara sen inodos dispoñibles, coa maioría dos paquetes non notaba nada pero como os numix crean unha burrada de arquivos individuais, daba erro.

    A culpa, en grande parte, tíñana uns 80 headers que foran quedando instalados sen kernel de referencia (kernels só teño 2). Ao final, entre tanto quita e pon, arranxa paquetes rotos, e tal e cual, xa entrara en bucle e non podía instalar nin desinstalar, nin reparar paquetes rotos, nin nada relacionado con operacións de paquetería. E ata que dei coa causa do problema dei tantas voltas que xa me estaba plantexando reinstalar todo.

    Vamos, que non me prestaría ter que reinstalar e igual non paga a pena o risco de actualizar o kernel cando queda un mes para a nova versión. Non sei, ireino pensando.

Deixa unha resposta

O teu enderezo electrónico non se publicará Os campos obrigatorios están marcados con *